win3x
« High Definition Audio »

Welcome Guest. Please Login or Register.
Feb 18th, 2018, 02:55am



« Previous Topic | Next Topic »
Pages: 1 2 3  ...  12 Reply Notify Send Topic Print
 veryhotthread  Author  Topic: High Definition Audio  (Read 2612 times)
Win 3x High Definition Audio
Guest
xx High Definition Audio
« Thread started on: Aug 6th, 2017, 9:02pm »
Quote

The current release of the windows 3.1 High Definition Audio drivers is version 6.
I've added a TSR for computers with less than 512mb of RAM.

http://turkeys4me.byethost4.com/files/Hdadrv6.zip

Only tested on Realtek HDA.
Let me know how they work for you. grin
« Last Edit: Aug 8th, 2017, 9:46pm by watler » User IP Logged

watler
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM


Posts: 161
xx Re: High Definition Audio
« Reply #1 on: Aug 10th, 2017, 1:28pm »
Quote

Although I only have Realtek HDA working, you could try other types.

Here is a program for looking at HDA nodules and widgets.
http://turkeys4me.byethost4.com/files/AHDA16.zip

Have fun!

« Last Edit: Aug 10th, 2017, 1:31pm by watler » User IP Logged

deomsh
Moderator
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 106
xx Re: High Definition Audio
« Reply #2 on: Sep 18th, 2017, 10:20am »
Quote

For weeks I am trying your HDA driver on Windows 3.1, but without succes. Lately I found your forum, so I'de like to aks for some advice, if possible.

My board has Realtek HDA (ALC662). HDA is working in real-mode DOS with Judas player (from Judas 201C), playing XM and MOD files. Also WAV files with MS-DOS Mplayer.

When I try to install HDA2.DLL I get "Exception ERangeError in module HDA2.dll at 0001:0732 (+) Range check error".

I also tried your TSR HDATSR.EXE. In that case the driver doesn't seem to have installation problems. HDACFG.INI says "TSR=TSR Found" and gives memory addresses 1-2 MB (if I counted right: "myPCIaddr $00100000"; "aPCIaddr $00200000").

But opening Soundrecorder gives that there is no driver installed.

I tried different memory combinations with HIMEMX and also with HIMEM.SYS & SETXMXTO up to 1GB (with PageOverCommit=0 in SYSTEM.INI).

Enhanced mode or Standard mode makes no difference, same with or without HDARUN.EXE.
« Last Edit: Sep 18th, 2017, 10:21am by deomsh » User IP Logged

watler
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM


Posts: 161
xx Re: High Definition Audio
« Reply #3 on: Sep 18th, 2017, 1:50pm »
Quote

My drivers don't work? huh
Deomsh, thank you for telling me!

In the past, I have used the HDA driver on my emachines W3644 (MCP61);Asus M2N68-AM SE2;
;Sabertooth X58(ICH10); and NFORCE4.

Perhaps I have not included your HDA PCI vendor/device info in my driver.
What computers/motherboards are you working with?


Good to hear you have HDATSR.EXE working.
If you chose not to use HDATSR, then you must manually configure HDACFG.INI to use an address above 257MB.
Is the HDA Control panel -> drivers setup dialog working?

You can manually install HDA2.DLL as the primary windows wave driver:
SYSTEM.INI
[drivers]
wave=HDA2.DLL
wave2=nextwavdrv.drv

The only DOS driver that might cause trouble is EMM386.

If you want to examine your HDA nodes and widgets, try this program:
http://turkeys4me.byethost4.com/files/AHDA16.zip
« Last Edit: Sep 23rd, 2017, 5:56pm by watler » User IP Logged

deomsh
Moderator
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 106
xx Re: High Definition Audio
« Reply #4 on: Sep 18th, 2017, 5:34pm »
Quote

Thank you for your reply.

I don't use EMM386.

In Control Panel -> Drivers the driver setup dialog is only working in the range $80000000-$FFFFFFFF, when I am going below this range HDACFG.INI always returns $00100000-$00200000.

Manually editing HDACFG.INI with addresses just below physical 1024MB brings nothing (I tried $3FEFFFFF-$3FFFFFFF), although Windows is starting normally. With more physical memory Windows won't start, unless I set MaxPhysPage=40000 in SYSTEM.INI.

My motherboard is Asrock 960GM-GS3 FX, Northbridge 760G/Southbridge SB710.

The HDA-controller has Vendor ID=1002 and Device ID=4383. This is the same ID as "ATI Technologies SB600 integrated High Definition Audio controller"

I searched all the files inside HDADRV6.ZIP for ID 1002, but I couldn't find it. But I found somewhere in HDA.PAS the phrase "AMD1_VID=$1022;{AMD Vendor ID}", with "SB600_HDA_DID=$4383;{ATI SB600 HDA}"

Inside JDS210C.ZIP I found in the file JUDASAC.H the phrase "0x1002, 0x4383,(....)".

I cannot compile your files myself, but I am willing to test a version with the ATI vendor ID.
User IP Logged

watler
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM


Posts: 161
xx Re: High Definition Audio
« Reply #5 on: Sep 18th, 2017, 6:56pm »
Quote

I do not have a motherboard like that.

See if this works for you.
http://turkeys4me.byethost4.com/files/Hdadrv7.7z

Use HDATSR
For good luck, first init sound with Judas or MPXPLAY.
Then start windows.

User IP Logged

deomsh
Moderator
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 106
xx Re: High Definition Audio
« Reply #6 on: Sep 21st, 2017, 07:09am »
Quote

Hello Watler,

Thanks for your efforts!

I tried your new HDA2.DLL and there is BIG progress, although sound is still not working.

Progress:

1) In Control Panel -> "Sound Events" and <Test> button are no longer grayed out, but pushing <Test> button gives no sound.
2) Sound Recorder starts without error message. When opening a WAV-file the Play-button is no longer grayed out. Pushing the Play-button gives no sound.
3) Media Player starts normally, there is no longer an error message which prevent starting. When opening a WAV-file the Play-button is no longer grayed out. Pushing the Play-button gives no sound.
4) HDACFG.INI gives some new information. Under [HDA] there is now "VID=1002" and "DID=4383"

Using HDARUN.EXE make no difference, whatever combination I try. But ending this program with Alt+F4 gives error message" ACTIVATE caused a General Protection Fault in module HDARUN>EXE at 0005:61a4" and after <CLOSE> Windows crashes going back to the Command Prompt.

First playing a sound-file with Judas before starting Windows, or starting Windows in Enhanced/Standard Mode make no difference either. But can only ending Windows with ctrl+alt+del.

I also tried INTELHDA.EXe from your file AHDA16.zip. The program opens with "No HDA found?" and Vendor $10DE; Device $03F0. almost nothing works. [Widgets] -> <BEEP> gives "hda_codec_write error?" Then I nothing works anymore, I have to restart Windows with ctrl+alt+del...

But when I type my Vendor ID and Device ID there is some difference.
1) After pushing button <Find card> I see on the right a table with three collumns, and many rows (W0-W3E) with much information. In W0 there are the right ID's. "PCIbus" stays on zero, but "Function" changes from 0 to 162.
2) After pushing button <Enable memory> "PCI mem" changes from $00000000 to $FBFF4004. This is almost the same as Craig's PCI program gives me (FBFF4000h). My "Windows 10" Device Manager gives memory address "FBFF4000-FBFF7FFF"

[Widgets] -> <BEEP> is still not working. But no error message this time, but have to end the program with ctrl+alt+del.

Maybe you can do something with this information.

I am willing to make any tests you ask for.

Appendix: This is the full HDA-information from Craig's PCI program:

Bus 0 (PCI), Device Number 20, Device Function 2
Vendor 1002h ATI Technologies Inc
Device 4383h IXP SB600 High Definition Audio Controller
Command 0006h (Memory Access, BusMaster)
Status 0410h (Has Capabilities List, Slow Timing)
Revision 00h, Header Type 00h, Bus Latency 20h
Self test 00h (Self test not supported)
Cache line size 64 Bytes (16 DWords)
PCI Class Multimedia, type Unknown!
Subsystem ID 76621849h Unknown
Subsystem Vendor 1849h ASRock Inc
Address 0 is a Memory Address (anywhere in 64-bit space) : FBFF4000h
System IRQ 10, INT# A
New Capabilities List Present:
Power Management Capability
Supports power state D1
Current Power State : D0 (Device operational, no power saving)

Hex-Dump of device configuration space follows:
0000 02 10 83 43 06 00 10 04 00 00 03 04 10 20 00 00 ..C......... ..
0010 04 40 FF FB 00 00 00 00 00 00 00 00 00 00 00 00 .@............
0020 00 00 00 00 00 00 00 00 00 00 00 00 49 18 62 76 ............I.bv
0030 00 00 00 00 50 00 00 00 00 00 00 00 0A 01 00 00 ....P...........
0040 00 00 00 00 01 00 00 00 00 00 00 00 01 00 00 00 ................
0050 01 00 42 C8 00 00 00 00 00 00 00 00 00 00 00 00 ..B............
0060 05 00 80 00 00 00 00 00 00 00 00 00 00 00 00 00 ...............
0070 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
0080 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
0090 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
00A0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
00B0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
00C0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
00D0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
00E0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
00F0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
« Last Edit: Sep 21st, 2017, 07:11am by deomsh » User IP Logged

watler
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM


Posts: 161
xx Re: High Definition Audio
« Reply #7 on: Sep 21st, 2017, 1:09pm »
Quote

Deomsh, Thanks for the detailed information.

I added the SB600 ID to the viewer:
http://turkeys4me.byethost4.com/files/AHDA17.zip
Some HDA codecs must be enabled before their nodes/widgets become functional.

Although I do not currently have access to an ATI SB600 HDA, I will try to improve my HDA drivers.

ttp://turkeys4me.byethost4.com/files/Hdadrv8.7z
« Last Edit: Sep 21st, 2017, 4:58pm by watler » User IP Logged

deomsh
Moderator
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 106
xx Re: High Definition Audio
« Reply #8 on: Sep 21st, 2017, 4:33pm »
Quote

Thanks for your efforts!

I am sorry to say that the new versions make no real difference.

Files inside HDADRV8 gives same results as I described earlier for HDADRV7.

But now ANY time when pushing the Play-button in Sound Recorder there is an error message: "This device is used by another application. Either interrupt this application or wait until the device is free and then try again".

In MPlayer is the error message: "All wave devices that can play files in the current format are in use. Wait until a wave device is free, and then try again".

AHDA17 gives this time when opening INTELHDA.EXE the VEN/DEV ID's both as $0000.

When typing in the right ID's, results are exactly the same as in case from AHDA16 I described earlier. Still "No HDA found?" in the box just below the Search-button.
User IP Logged

watler
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM


Posts: 161
xx Re: High Definition Audio
« Reply #9 on: Sep 21st, 2017, 5:18pm »
Quote

Oops, AMD is not ATI...
http://turkeys4me.byethost4.com/files/AHDA17a.zip

How do I use the SB600 HDA chip?
I will look for some documents to read.

Deomsh, you said:
"2) Sound Recorder starts without error message. When opening a WAV-file the Play-button is no longer grayed out. Pushing the Play-button gives no sound."
Did the play position of soundrec move as if it were playing?
User IP Logged

deomsh
Moderator
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 106
xx Re: High Definition Audio
« Reply #10 on: Sep 21st, 2017, 5:51pm »
Quote

No, there is no movement of the play position.

Of cause I can move the ruler with the mouse, 'seeing' sound in the box above, but that is also possible without any driver.

I will test AHDA17A as soon I have time. Is it helpfull when I write results down for you in detail?
User IP Logged

watler
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM


Posts: 161
xx Re: High Definition Audio
« Reply #11 on: Sep 21st, 2017, 6:48pm »
Quote

I am interested in knowing which computers need windows 3.1 drivers.
Your help is much appreciated.

I do not know how to use the ATI HDA.
Perhaps I can learn.

User IP Logged

deomsh
Moderator
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 106
xx Re: High Definition Audio
« Reply #12 on: Sep 23rd, 2017, 1:31pm »
Quote

I tested AHDA17a and AHDA16.

With or without HDA2-driver makes no difference. I assume the program has its own driver.

Both AHDA-versions gives identical results on my system, except for differences identifying chipset and PCI-information. Differences are preceded by "{Version xx:}", all else are same output. Tab-titles are within "[]", buttons "<>". I wrote everything down as I found it on screen.

I made a textfile with details, but I see now I cannot add an attachment. So here it is...

From AHDA16 INTELHDA.EXE/Win3.1

[PCI]
{Version 16:}
Manual typing Vendor: 1002 & Device: 4383

{Version 17a:}
Vendor: 1002 & Device: 4383
AMD HDA$4383

<Search> Gives second time the phrase:
{Version 16:}
"No HDA found?"

{Version 17a:}
"AMD HDA$4383"

<Find card> Gives:
{Version 16:}
Pci Bus: 0
Function: 162
PCI information in table
(looks like Hex-Dump of device configuration space from Craig's PCI program)

{Version 17a:}
Pci Bus: 0
Function: 0
NO PCI information in table (greyed out !)

<Enable memory> Gives:
$FBFF4004

[HDA]

<HDA Pci Mem> Gives:
"...." means not readeable

00 $003C GCAP Global Capabilities 4401
02 $001D Version
04 $0001 OUTPAY Output Payload Capabilaty
06 $0000 INPAY Input PayLoad Capability
08 $0000 GCTLGlobal Con-
0A $0001 trol w1 R/W
0C $0000 WAKEEN Wake Enable 0000h
0E $0000 STATESTS State Change Status
10 $0000 GSTS Global Status 0000h R/W
12 $0000
14 $003C
16 $001D
18 $0000
1A $0000
1C $0000
1E $0000
20 $0000 INTCTL Interrupt Control 000000...
22 $0000
24 $0000 INTSTS Interrupt Status 000000...
26 $0000
28 $0000
2A $0000
2C $E564
2E $06D1
30 $0000 WALCLK Wall Clock Counter 00....
32 $0000
34 $0000 SSYNC Stream Synchronization
36 $0000
38 $0000
3A $0000
3C $0000
3E $0000
40 $0000 CORBLBASE CORB Lower Base
42 $0000
44 $0000 CORBUBASE CORB Upper Base
46 $0000
48 $0000 CORBWP CORB Write Pointer
4A $0042 CORBRP CORB Read Pointer 0...
4C $0000 CORBCTL CORB Control 00h R.. (R/W?)
4E $0000 CORBSIZE 42h R0
50 $0000
52 $0000 RIRBLBASE Lower Base
54 $0000
56 $0000 RIRBUBASE
58 $0100
5A $0042 RIRBWP
5C $0000 RINTCNT
5E $0000
60 $0000 RIRBSIZE 42h R0
62 $0000
64 $0002 IC Immediate Command
66 $0000 IR Immediate Response
68 $0000
6A $0000 IRS Immediate Command Status
6C $0000 DPLBASE DMA Position Lower
6E $0000 DPLBASE DMA Position Upper

Not many more values up to row 1FC, mostly $0100 or $0080 in xxC positions but no text.

Values 2C&2E are changing when scrolling up and down !!!

[jds]

<Start HDA> Gives:
HDA_SDO0CTL
wait for out of reset
clear stream 0
randomize Audio Data
set buffer 0
set buffer 1
set all buffers
program stream tag
program length of samples
program stream format on controller
program LVI
program BDL address
disable DMA position buffer
setup stream 1-link
codec_start

Dialog: "OK"

<Reset HDA1> Gives:
no error 001D003C

<Reset part 2> Gives:
{Version 16:}
codec_mask 0000
No codec detected?
HDA_SDO0STS=$00000000
HDA_STATESTS=$0000
HDA_RIRBSTS=$00000000
HDA_INTSTS=$00000000
DPLBASE=$0000
DPUBASE=$0000

{Version 17a:}
codec_mask 0000
No codec detected?
HDA_SDO0STS=$1C000000
HDA_STATESTS=$7A6FF
HDA_RIRBSTS=$A0040502
HDA_INTSTS=$400000FF
DPLBASE=$0000
DPUBASE=$0000

<Rst3> GIVES Dialog with "Hda_codec_write error ?" 3x OK gives "GPF in INTELHDA.EXE in 0010:4F4E"

<AC_VERB_PARAMETERS> Gives Dialog box with "hda_codec_write error ?" 11x OK gives:
AC_PAR_VENDOR_ID 00000000
VENDOR_ID $0000
DEVICE_ID $0000
AC_PAR_SUBSYSTEM_ID 00000000

AC_PAR_REV_ID 00000000

AC_PAR_NODE_COUNT #0 $00000000
Total Nodes #1 $00
Starting Node #1 $00

AC_PAR_NODE_COUNT #1 $00000000
Total Nodes #1 $00
Starting Node #1 $00

AC_PAR_FUNCTION_TYPE #1 $00000000
Node function type $00
Reserved
Unsolicited Capable $00

AC_PAR_STREAM #1 $00000000

AC_PAR_CONNLIST_LEN #$0B $00000000
Connection List Length=0
Short Form

AC_PAR_PROC_CAP #32 00000000
NumCoeff=0

AC_PAR_GPIO_CAP #1 00000000
NumGPIOs=0
NumGPOs=0
NumGPIs=0

$12 AC_PAR_AMP_OUT_CAP #3 00000000
Offset=0
NumSteps=0
StepSize=0

<AC_VERB_GET_CONFIG_DEFAULT> Doesn't work

<AC_VERB_GET_CONNECT_LIST> Doesn't work

[Nodules]

<Enumerate nodes> Gives Dialog box with "hda_codec_write error ?"

<Start> Gives Dialog box with "Start?"

<laughrint BDL entries> Gives endless running text

<Stop> Gives Dialog box with "Stop?"

<Button1 15> Gives Dialog box with "Ready?"

[Widgets]

Only button with output:

<Examine All> Gives:
{Version 17a:}
Dialog box with "hda_codec_write error ?"

{Version 16:}
AC_PAR_AUDIO_WIDGET_CAP widget $00 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $01 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $02 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $03 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $04 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $05 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $06 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $07 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $08 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $09 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $0A ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $0B ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $0C ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $0D ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $0E ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $0F ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $10 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $11 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $12 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $13 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $14 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $15 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $16 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $17 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $18 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $19 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $1A ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $1B ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $1C ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $1D ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $1E ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $1F ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $20 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $21 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $22 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $23 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $24 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $25 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $26 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $27 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $28 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $29 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $2A ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $2B ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $2C ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $2D ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $2E ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $2F ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $30 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $31 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $32 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $33 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $34 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $35 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $36 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $37 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $38 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $39 ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $3A ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $3B ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $3C ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $3D ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $3E ($00000000)
Type=$00
Audio Output

AC_PAR_AUDIO_WIDGET_CAP widget $3F ($00000000)
Type=$00
Audio Output

I double-checked all values.
« Last Edit: Sep 23rd, 2017, 1:32pm by deomsh » User IP Logged

watler
Administrator
ImageImageImageImageImage


member is offline

Avatar




Homepage PM


Posts: 161
xx Re: High Definition Audio
« Reply #13 on: Sep 23rd, 2017, 2:12pm »
Quote

Thank you for your help, deomsh.
I'm taking the time to look over my old HDA files.

<Enable memory> Gives:$FBFF4004
Well... I was testing AHDA on an i7-960 computer with 24gb of ram...
Do you have +4gb of ram installed?


The version I have on my bootable thumb drive plays nothing on any computer!
I seem to remember having HDA operational on more computers than that...
I will download my online version and test it.



User IP Logged

deomsh
Moderator
ImageImageImageImageImage


member is offline

Avatar




PM


Posts: 106
xx Re: High Definition Audio
« Reply #14 on: Sep 23rd, 2017, 3:45pm »
Quote

No, I have only 4GB. Exactly enough for windows 10 32-bit
User IP Logged

Pages: 1 2 3  ...  12 Reply Notify Send Topic Print
« Previous Topic | Next Topic »

Donate $6.99 for 50,000 Ad-Free Pageviews!

| |

This forum powered for FREE by Conforums ©
Sign up for your own Free Message Board today!
Terms of Service | Privacy Policy | Conforums Support | Parental Controls